LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
[lammps-users] Build process of module ATC
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lammps-users] Build process of module ATC

From: Reuti <reuti@...7280...>
Date: Wed, 13 Dec 2017 11:56:48 +0100


I'm in the process of compiling LAMMPS including some modules, starting with ATC. After checking src/USER-ATC/README it pointed me to lib/atc/README and I see three ways to compile it. I tried them in order and the Python-way (doing it either with:

$ make lib-atc args="-m mpi -e atc" (inside src)


$ python -m mpi -e atc (inside lib)

) led both to an error message:

foo@...7281...:~/lam_development/lammps-11Aug17/lib/atc> python -m mpi -e atc
Building libatc.a ...
Traceback (most recent call last):
  File "", line 95, in <module>
    txt = subprocess.check_output(cmd,shell=True,stderr=subprocess.STDOUT)
  File "/home/software/python-2.7/lib/python2.7/", line 573, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command 'make -f clean; make -f -j32' returned non-zero exit status 2

Is there any special version of Python necessary? Right now 2.7.11 is installed.


On the other hand, then I tried the third way to execute:

foo@...7281...:~/lam_development/lammps-11Aug17/lib/atc> make -f Makefile.mpi

and despite a bunch of "may be used uninitialized in this function" warnings it succeeded an I got a libatc.a and Makefile.lammps


Is the Python way of building it broken or the a plain `make` the favored way anyway?

-- Reuti