LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] packages
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] packages

From: Michał Kański <michal.kanski@...2460...>
Date: Fri, 3 Nov 2017 22:30:29 +0000

Please always add LAMMPS mailing list to recipients.

The tutorial you've linked to is outdated. You only need to go to the "src" directory, install (by make yes- commands) packages you require, and type "make machine". If you had overwritten any Makefile files, you should delete the entire LAMMPS directory and unpack it again.


From: Monika Choudhary <mc805@...7210...>
Sent: Friday, November 3, 2017 8:49:07 PM
To: Michał Kański
Subject: Re: [lammps-users] packages
Hi Michal

I am trying to rebuild it
and coming out with more mess

Earlier there was a problem with fdt command but now I am not even able to execute-- make ubuntu

I am following this link to rebuild

Attachment:Error (while using make ubuntu)

On Fri, Nov 3, 2017 at 8:18 PM, Michał Kański <michal.kanski@...2460...> wrote:
Are you certain you use the recompiled executable? The directory path suggests you downloaded 23Oct17 LAMMPS version yet the output starts with "17 Nov 2015".


On 3 November 2017 12:29:30 CET, Monika Choudhary <mc805@...7212......> wrote:
Hi Micheal

Yes I did that also
Initially I installed the package
and after that I recompiled using -------   "make mpi"

Even after this I am getting the same error.

Attached is the screenshot -

On Fri, Nov 3, 2017 at 4:44 PM, Michał Kański <michal.kanski@...2460...> wrote:
"make yes-" only prepares files for compilation. You have to recompile LAMMPS.

More information here:


On 3 November 2017 08:50:17 CET, Monika Choudhary <mc805@...7212......> wrote:
Is it possible to install packages after installing LAMMPS.
Actually I have already installed all the packages but when I was using pair_style dpd/ftd it is showing some error like unknown pair style.

so I tried to reinstall it by using following command

make no-USER-DPD
make yes-USER-DPD

and when I am checking the package status using make pacjkage status then it is coming in the list.

I don't know what went wrong.