LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] Python and animations
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] Python and animations

From: Gideon Simpson <gideon.simpson@...24...>
Date: Thu, 12 Oct 2017 08:24:14 -0700

ffmpeg is installed on the Mac, and if I run a standard (i..e, non-python) lammps script with the dump movie command, it works as expected.


On Oct 12, 2017, at 6:38 AM, Richard Berger <richard.berger@...1545...> wrote:

dump movie requires ffmpeg. That isn’t IPyLammps specific, but is always the case. Is it installed on the mac? If so maybe its PATH is somehow messed up. Otherwise I’d have to see the scripts.

PS: I’m the author of both PyLammps and IPyLammps. IPyLammps just adds a few utilities for IPython notebooks. In this case allowing to embed a generated video.


On Thu, Oct 12, 2017 at 09:24 Steve Plimpton <sjplimp@...24...> wrote:
CCing Richard,  IPyLAMMPS is not part
of LAMMPS, right?  Is there an author you can
ask these Qs to directly?


On Wed, Oct 4, 2017 at 6:14 PM, Gideon Simpson <gideon.simpson@...24...> wrote:
I’m finding that on one of my machines (a Mac), I can’t dump my output to a movie from a IPyLammps script with the command:

L.dump("3 all movie 100 anim.mpeg type type adiam 1.0")

The same script, run on a linux machine, has no problem.  There is also no problem on the Mac if I run this as a standard script with the command line.  Any suggestions on how to troubleshoot/resolve  this?


Check out the vibrant tech community on one of the world's most
engaging tech sites,!
lammps-users mailing list

Dr. Richard Berger  richard.berger@...1545...      Office: SERC 701F
Research Assistant Professor, Dept. of Mathematics, College of Science and Technology
Temple University, Philadelphia PA 19122