LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
[lammps-users] Issues with fix rigid in PRD simulation
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lammps-users] Issues with fix rigid in PRD simulation

From: Mohammad Rasool Vazirisereshk <mvazirisereshk@...24...>
Date: Fri, 25 Aug 2017 15:43:44 -0700

Hi everyone,

 I am using the latest stable version of LAMMPS (11 Aug 2017) and have a question about the use of REPLICA and rigid packages, concurrently at a simulation. 

The problem I am working on is simplified as follows: I have a tip moving laterally on a substrate. The top part of the tip is rigid (using fix rigid) and coupled to an atom moving laterally with constant speed (using fix move). This setup works perfectly in regular MD. However, when I use prd command the system shows strange behavior (the tip sometimes either penetrates in the substrate or flies over simulation box). Below you can find a part of my input file: 

# 1 fs time step
timestep 0.001
variable t equal 300


fix 1 lo-mid nvt temp 300.000000 300.000000 1
fix 90 hi-mid nvt temp 300.000000 300.000000 1
fix 91 free nve
fix 2 lo-fixed setforce 0.0 0.0 0.0
fix 10 hi-fixed addforce 0.0 0.0 -0.003613

fix 3 hi-fixed rigid single torque 1 off off off
fix 4 hi-fixed spring couple virtual 4.0 0.0 NULL NULL 0.0

#virtual atom
fix 7 virtual setforce 0.0 0.0 0.0
fix 8 virtual move linear 0.01 0.0 0.0 units box

I guess the problem is due to having fix rigid command in the prd simulation since I ran the prd simulation for a similar setup, which did not have fix rigid, without any problem.

I also tried to use fix aveforce (0 0 0) instead of fix rigid in my prd simulation but it did not work out. 

Is there anyone else who faced irregularities with fix rigid in prd simulation? Any idea or comment will be appreciated.