LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] problem with running lammps in parallel
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] problem with running lammps in parallel

From: Axel Kohlmeyer <akohlmey@...24...>
Date: Tue, 1 Aug 2017 02:01:11 -0400

On Tue, Aug 1, 2017 at 1:44 AM, Neda Rafiee via lammps-users <> wrote:
Dear all,
I have a problem with running lammps in parallel. Actually, I installed lammps on my home on IPM cluster. I copied my data and input files into lammps/src and then used the following command:

./lmp_mpi -in in.myfile

It worked, but it's too slow; (because of using only one processor). I tried to use the following command to made it faster:

mpirun -np 16 lmp_mpi -in in.myfile

But I got this error: " HYDU_create_process (utils/launch/launch.c:75): execvp error on file lmp_mpi (No such file or directory)". Could you please tell me how I should do it?

​this is not a LAMMPS problem, but related to your MPI library and a property of Linux/Unix systems where the current working directory is not part of the search path for executables. mpirun complains, that your lmp_mpi executable cannot be found in a folder listed in $PATH.
if you compare the two​ command lines, you should see a significant difference that is commensurate with my explanations above.



Check out the vibrant tech community on one of the world's most
engaging tech sites,!
lammps-users mailing list

Dr. Axel Kohlmeyer  akohlmey@...12...24...
College of Science & Technology, Temple University, Philadelphia PA, USA
International Centre for Theoretical Physics, Trieste. Italy.