LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] Fix Deposit and Particle Insertion Discrepancy
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] Fix Deposit and Particle Insertion Discrepancy


From: MASATO KOIZUMI <mkoizumi@...3709...>
Date: Sun, 27 May 2018 19:45:08 -0700

Dear Ms. Tara Majdi,

Thank you so much for your time in providing me with your advice. Following your suggestion, I noticed that the first molecule was inserted into my simulation domain at timestep 1

According to the following fix deposit command,

fix    4 addatoms deposit 3 1 100000 12345 region mobile near 0.0 mol dimer vx 0 0 vy 0 0 vz 0 0

I am expecting the first molecule to be inserted at timestep 100000. However, it is evident that the molecule was inserted at timestep 1 and the second molecule was inserted at timestep 100001 such that at two inserted molecules exist at the start of 100001 until 200000 timestep. The third molecule was inserted at timestep 200001 thereby three molecules present at the start of 200001 and at 300000 timestep. Therefore, I have a total of 3 molecules at the end of the simulation that lasts for 300000.

The total number of atoms at the end of my simulation is consistent to the value I specified in my script. 

I was curious if it is possible for the first molecule to be inserted at M = 1000 timestep. 

Once again, I deeply appreciate your time and effort in providing me with your advice.

Sincerely,

Masato Koizumi

On Sun, May 27, 2018 at 1:17 PM, T. Majdi <majdit@...1849...> wrote:
Hi Masato,

I suggest adding

thermo_style custom step time atoms
thermo 1

only during deposition of a shorter test run. The output will show you the number of atoms in each step. Then you can see exactly in which time step the number of atoms in your system increased.

Is the total number of atoms at the end of your simulation what you expect it to be based on your script?

Regards,
Tara 



On Sun, May 27, 2018 at 3:54 AM, MASATO KOIZUMI <mkoizumi@...3709...> wrote:
Dear LAMMPS Users,

Hello. I was curious if I could ask a question regarding the fix deposit command.

I understand that fix deposit command inserts a single atom or molecule into the simulation domain every M timesteps until N atoms or molecules have been inserted. 

In my MD simulation, I have 

fix    4 addatoms deposit 10 0 1000 12345 region mobile near 0.0 mol dimer vz -1 -1

My simulation runs for 10000 and my simulation box is changing in size with periodic boundary conditions.

I output a dump file every 50 timesteps, and when I look at my dump file that was generated at 50 timestep, I see that the molecule has already been inserted. I check with OVITO, which confirmed that the first molecule was inserted at 50 timesteps when in fact, the first molecule should have been inserted at 1000 timesteps. The second molecule was inserted at 1000 timesteps consistent with the parameters I specified in my fix deposit command

I would greatly appreciate if I could request an advice on why the first molecule is being inserted at 50 timestep and not at 1000 timesteps. 

Thank you.

Sincerely,

Masato Koizumi

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
lammps-users mailing list
lammps-users@...655....net
https://lists.sourceforge.net/lists/listinfo/lammps-users




--
Tahereh Majdi, B.Eng., M.A.Sc.
PhD candidate, Engineering Physics
McMaster University

e:majdit@...1849...
t: (905)-541-3814