LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] Buckingham Potential
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] Buckingham Potential


From: Afza Shahid <afza_shahid@...16...>
Date: Thu, 17 May 2018 08:07:22 +0000 (UTC)

Dear Steve 
I have run the simulation using arbitrary values for coefficients of buckingham potential and there is no error but when I give the actual values of coefficients of Buckingham potential there an error saying All pair coeff are not set. Input script is given below:

# ---------- Initialize Simulation --------------------- 
clear 
units metal 
dimension 3 
boundary p p p 
atom_style atomic 
atom_modify map array

# ---------- Create Atoms --------------------- 
read_data YzOO.in
#lattice fcc 4
#region box block 0 1 0 1 0 1 units lattice
#create_box 1 box

#lattice fcc 4 orient x 1 0 0 orient y 0 1 0 orient z 0 0 1  
#create_atoms 1 box
mass 1 88.90
mass 2 91.22
mass 3 16.0
#replicate 1 1 1

# ---------- Define Interatomic Potential --------------------- 
pair_style buck 2.5
pair_coeff 1 3 2442.60 0.3054 17.51   #Y-O interaction
pair_coeff 2 3 1402.57 0.3312 5.10     #Zr-O interaction
pair_coeff 3 3 35686.18 0.2010 32.00  #O-O interaction
neighbor 2.0 bin 
neigh_modify every 1 delay 0 check yes
 
# ---------- Define Settings --------------------- 
compute eng all pe/atom 
compute eatoms all reduce sum c_eng 

# ---------- Run Minimization --------------------- 
reset_timestep 0 
fix 1 all box/relax iso 0.0 vmax 0.001
thermo 10 
thermo_style custom step pe lx ly lz press pxx pyy pzz c_eatoms 
min_style cg 
minimize 1e-25 1e-25 5000 10000 

variable natoms equal "count(all)" 
variable teng equal "c_eatoms"
variable length equal "lx"
variable ecoh equal "v_teng/v_natoms"

print "Total energy (eV) = ${teng};"
print "Number of atoms = ${natoms};"
print "Lattice constant (Angstoms) = ${length};"
print "Cohesive energy (eV) = ${ecoh};"

print "All done!" 


I have run the simulation with the pair coeff command given below (supposed values for coefficients) and it shows no error.
pair_style buck 2.5
pair_coeff * * 100.0 1.5 200.0 

Kindly help me where exactly the problem is.

Regards
Afza Shahid.



On Tuesday, May 15, 2018 7:16 PM, Steve Plimpton <sjplimp@...24...> wrote:


Please put the input script lines and the error message in your mail post.

Steve

On Tue, May 15, 2018 at 2:58 AM, Axel Kohlmeyer <akohlmey@...24...> wrote:


On Tue, May 15, 2018 at 4:17 AM, Afza Shahid via lammps-users <lammps-users@...396... sourceforge.net> wrote:
Dear LAMMPS users

I'm using this command:

pair_style buck 20
pair_coeff * * 2442.60 0.3054 17.51

cut off= 20A
A= 2442.60 A
rho= 0.3054 eV
C= 17.51 eV A^6

but there is an error saying that these parameters are out of bound. Can anybody help me with this problem. Whats wrong with this command.

‚Äčnothing. ‚Äč

 

Regards 
Afza Shahid

------------------------------ ------------------------------ ------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
______________________________ _________________
lammps-users mailing list
lammps-users@...655... .net
https://lists.sourceforge.net/ lists/listinfo/lammps-users




--
Dr. Axel Kohlmeyer  akohlmey@...24...  http://goo.gl/1wk0
College of Science & Technology, Temple University, Philadelphia PA, USA
International Centre for Theoretical Physics, Trieste. Italy.

------------------------------ ------------------------------ ------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
______________________________ _________________
lammps-users mailing list
lammps-users@...396... sourceforge.net
https://lists.sourceforge.net/ lists/listinfo/lammps-users