LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
[lammps-users] Crash when trying to loop script
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lammps-users] Crash when trying to loop script


From: Gonçalo Paulo <g-spaulo@...8...>
Date: Sat, 5 May 2018 19:22:57 +0000

Hi,

I'm not sure if this is lammps problem or a bad mpi build but if I try to loop any script it fails with a segmentation fault in every third or fourth loop. It goes with no other problem with the other runs but it crashes after some tries. To try to find the problem i've even setup a simple script that just runs one time after setting up simple stuff and it still crashes, here it is:

"

label loop

variable L      loop  1 10

units lj
atom_style full
boundary p p p
dimension 2

lattice       sq2 1
region        box block 0 80 0 80 -0.5 0.5
create_box   2 box
create_atoms 1 box
mass       * 1.0

change_box all y final 0 190 units box
change_box all x final 0 190 units box
displace_atoms all move 1 1 0 units box

velocity all create 1 1000 dist gaussian mom yes rot yes

# only excluded volume interaction
pair_style lj/cut 4 
pair_coeff * * 1.0 1.0 1.122
pair_modify     shift yes

neighbor 1 multi
neigh_modify delay 0 page 100000
comm_modify     mode multi

fix   3 all nve
fix   5 all enforce2d

timestep 0.01

thermo 1000
thermo_modify flush yes

run    1
clear
next L
jump ../../capillary/in.teste loop
"
../../capillary/in.teste is where the script is located and it gives the same error with SAME instead. My input is : mpirun -np 8 ./lmp_mpi -in ../../capillary/in.teste and it crashes even if i just do ./lmp_mpi so I'm not sure what is causing the problem.
I can run single runs just fine, any help would be apreciated.

Gonçalo