LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
[lammps-users] Rigid body breaking
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lammps-users] Rigid body breaking


From: Mohd Ibrahim <mihph12@...24...>
Date: Tue, 19 Dec 2017 12:09:55 +0530

Dear LAMMPS developers,
                                   I have a polymer system confined between two crystalline walls. The wall atoms are assigned as rigid body. Force and torque on both the walls is set to zero. The interaction among wall atoms is switched off. 
In order to calculate viscosity I shear the system by moving one of the wall while keeping the other wall fixed. I used a fix move command to do so. But after some time the moving wall is deforming and breaking apart although force and torque on it due to other particles in the system is set to zero and the wall atoms don't interact among each other. 
I would be much grateful if any one could help. Here is the part of input script where it is breaking apart. 
velocity wal_lo set 0 0 0 units box
fix 24 wal setforce 0.0 0.0 0.0
fix 26 wal  rigid/nvt group 2 wal_hi wal_lo temp 1.0 1.0 0.1 force * off off off torque * off off off
fix        6 wal_hi move linear 1 0 0 units box
dump            21 all custom 5000 eq_shear.lammpstrj id mol type xu yu zu vx vy vz 
dump            27 poly custom 5000 eq_shear_poly.lammpstrj id mol type xu yu zu vx vy vz 
restart 5000000 shear
run 5000000
The wal group  contains both wal_lo and wal_hi
Thank You ,
Ibrahim