LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] rerun command
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] rerun command

From: Steve Plimpton <sjplimp@...24...>
Date: Wed, 15 Nov 2017 14:47:48 -0700

This usually happens b/c when you do a rerun you are
not processing dump files that match all the timesteps
that the fix ave/histo command expects to be called on.
What timesteps are your dump files written on?


On Thu, Nov 9, 2017 at 6:31 AM, Mirshekariyan Babaki, Mehrnaz <mehrnaz.babaki@...1516...> wrote:

Dear all,

I am using the lammps-17Nov16 version of LAMMPS and I want to use the compute cluster command to write a histogram of cluster size. 

First I dumped the trajectories during a MD run with "dump 1 all atom file.lammpstrj" command. After the MD run is completed I tried to compute the cluster size with the following lines:

read_restart file.*.restart

compute cluster all cluster/atom 2.5

compute cc1 all chunk/atom c_cluster compress yes

compute size all property/chunk cc1 count

fix 1 all ave/histo 1000 1 1000 0 30 30 c_size mode vector ave running beyond ignore file tmp.histo

rerun file.lammpstrj dump x y z

However, when the simulation was finished, nothing was written in the histogram output file (tmp.histo), unless the header lines.

Could anyone suggest why the file is not properly generated?

Check out the vibrant tech community on one of the world's most
engaging tech sites,!
lammps-users mailing list