LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] About temperature fluctuations
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] About temperature fluctuations


From: Axel Kohlmeyer <akohlmey@...24...>
Date: Mon, 13 Nov 2017 10:23:51 -0500



On Mon, Nov 13, 2017 at 10:04 AM, A. M.M <alaa.murar@...24...> wrote:
بسم الله الرحمن الرحيم

Hello,

Thanks a lot for your reply.

I have attached the inputs file of my system.

In the second paragraph, I mean when I put Tstart=Tstop=298.15 K in fix_langevin command I will get a fluctuations around 150-160 K and an ave/time/temp around 150 K, but to get a fluctuations and ave/time/temp around 298.15 K I can increase Tstart and Tstop = 2*298.15 K. Now Can I say that the results of my simulation are in ( ave/time/temp that I get which is around 298.15 K ) or in what I used in fix_langevin command which is 2*298.15 K ?

​i think you can safely say, that your simulation results are crap.

try running without thermostat and check whether you can run a stable simulation that conserves (total) energy​.
if not, reduce your time step until you can. then turn the thermostat back on and see what happens.

axel.


 

Thank you

On Mon, Nov 13, 2017 at 4:08 AM, Axel Kohlmeyer <akohlmey@...24...> wrote:


On Sat, Nov 11, 2017 at 11:09 AM, A. M.M <alaa.murar@...24...> wrote:
بسم الله الرحمن الرحيم

Hello LAMMPS user,

I used fix_langevin command with fix_nve to perform a BD as mentioned in LAMMPS documents, I put Tstart=Tstop=298.15 K (25 C) and damp = 482 fmsec. Also, I used a time step = 300.0 fmsec, and my system is a 24 bead-spring chain.

My simulation run well, but I noticed that the temperature fluctuates below the value that I put in the command, and when I calculate the ave/time/temp I also got around 150-160 K. what is/are the reason/s ?

​there is not enough information to answer this question. most likely, you are making a mistake somewhere.​
 

I can increase the values in the command until I get a fluctuations around 298.15 K and also an ave/time/temp around this value, but now Can I say that the results of mu simulation are in ( ave/time/temp that I get ) or in what I used in the command ?


what values in what commands? what exactly are you asking​ here?


good answers require well posed questions with sufficient detail.

axel.

 

Thank you

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
lammps-users mailing list
lammps-users@...655....net
https://lists.sourceforge.net/lists/listinfo/lammps-users




--
Dr. Axel Kohlmeyer  akohlmey@...24...  http://goo.gl/1wk0
College of Science & Technology, Temple University, Philadelphia PA, USA
International Centre for Theoretical Physics, Trieste. Italy.




--
Dr. Axel Kohlmeyer  akohlmey@...24...  http://goo.gl/1wk0
College of Science & Technology, Temple University, Philadelphia PA, USA
International Centre for Theoretical Physics, Trieste. Italy.