LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] Improved performance for setup on large numbers of MPI ranks
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] Improved performance for setup on large numbers of MPI ranks


From: Christopher Knight <cjknight2009@...24...>
Date: Thu, 26 Oct 2017 17:00:46 -0500

Stan,

Awesome!

I know what you mean. In the multi-billion particle use cases that motivated all this, I couldn’t even run jobs long enough to start step 0 with replicate + molecule_setup + pppm_setup together...

chris



On Oct 26, 2017, at 4:47 PM, Moore, Stan <stamoor@...3...> wrote:

Chris,

I tried out your change using 16384 MPI ranks with my original triclinic system and it works great. I'm replicating a ~300 atom perfect crystal up to 0.5 billion atoms, so your enhancement to replicate is really helpful! With the original replicate command, every MPI rank had to loop over half a billion atoms and it took a really long time.

Thanks,

Stan

-----Original Message-----
From: Christopher Knight [mailto:cjknight2009@...24...] 
Sent: Thursday, October 26, 2017 3:13 PM
To: Moore, Stan <stamoor@...3...>
Cc: akohlmey@...24...; lammps-users@lists.sourceforge.net
Subject: [EXTERNAL] Re: [lammps-users] Improved performance for setup on large numbers of MPI ranks

Hi Stan,

Yup, I saw the note. I think I have replicate working with triclinic systems; waiting for verification in large tests queued up. Input and source attached if you want to try before commit,

chris