LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] bond atom missing in image check
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] bond atom missing in image check


From: Stefan Paquay <stefanpaquay@...24...>
Date: Wed, 18 Oct 2017 11:19:00 -0400

Please always include the mailing list in replies.

Restart should "just work", I do now know why it would fail in your case. You can use dump custom and write the periodic images in addition to all coordinates and atom ids/types. See the "dump custom" docs.

On Wed, Oct 18, 2017 at 11:15 AM, Hossein Geraili <geraili.hsn@...12...24...> wrote:

Thank you Stefan,
I used write_restart and the error did not assign all restart atoms correctly occured. Do you think with write_data it would be solved. Are there any other extention besides .xyz that would save priodic images?
Best


On Oct 18, 2017 6:38 PM, "Stefan Paquay" <stefanpaquay@...24...> wrote:
Also, there are ways to make sure the simulation keeps running even after your connection drops (e.g., tmux or GNU screen or a simple nohup and a &).

On Wed, Oct 18, 2017 at 11:07 AM, Stefan Paquay <stefanpaquay@...24...> wrote:
No. What probably goes wrong is that an xyz file does not store box images, so when LAMMPS tries to reconstruct the actual position of atoms that are straddled across the periodic boundary it cannot do so. You need the periodic images. If you want to resume from a dump file, you need to also dump the periodic images. Alternatively, use a write_restart or write_data to restart from.

On Tue, Oct 17, 2017 at 10:31 PM, Hossein Geraili <geraili.hsn@...24...> wrote:

Just tell me, if I run for more timestep I can use .xyz coordinations or restart. Because actually, I did not exit the simulation in the parallel simulation on my computer whenever internet is disconnected tthe simulation would be exited. This is the third time that I am going near 100 microsecond and simulation exits. Please help me, so I can finish simulation for 1 nanoseconds.
Best regards


On Oct 17, 2017 9:06 PM, "Hossein Geraili" <geraili.hsn@...24...> wrote:
Dear all,
I am running in NPT ensemble for 300 molecules of ionic liquid with AMber force field. I ran for a small number of steps about 50 microseconds and then I wanted to use atom positions in this state which seems to be equilibrated state for next simulations. I used positions in .xyz file of dump command and substitute them in the data file. First I ran it serial and the warning of bond/angle/dihedral extent > half of periodic box length showed up and after that error of bond atom missing error occurred. In the parallel simulation, the simulation was exited with the error of bond atom missing in image check. Also, I tried using restart, but it exited with the error of did not assign all restart atoms correctly, and I even used remap command but it did not work. 
All the bonded and nonbonded energy are in good agreement with the article data.
what is wrong?
best
--
Hosein Geraili Daronkola
M.Sc.Graduated of physical chemistry
Physical Chemistry,
Department of Chemistry,
Sharif University of Technology.
geraili_hosein@...7110...



Sent with Mailtrack

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
lammps-users mailing list
lammps-users@...655....net
https://lists.sourceforge.net/lists/listinfo/lammps-users