LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] FW: Restart not exact
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] FW: Restart not exact


From: Stefan Paquay <stefanpaquay@...24...>
Date: Fri, 6 Oct 2017 14:24:42 -0400

Hi Soumyadipta,

I would think that, since restart files are binary, the numbers should be completely identical if the simulation setup is completely identical. Perhaps some of the commands issued in the original script do not store their settings in the binary restart file?
Magically, only the pair energies seem different. Can you check the logs to see if cutoffs, shifts etc. are the same between the two runs?

As to whether or not the difference is acceptable: I would not feel comfortable assessing that until the reason for the difference is known.

On Fri, Oct 6, 2017 at 2:03 PM, Sengupta, S. <S.Sengupta@...2493...> wrote:
Dear users,

I ran a simulation using lambda_test.txt . I am trying to restart the simulation from 2950000 time steps using lambda_rst.txt. I am using the lammps 17Nov/16 version.

The thermo diagnostics for restart are not exactly matching the 2950000 time step data in the log file. I have kept the number of processors same and used the default newton setting in both the restart and original simulation.

Restart thermo

Step Temp E_pair E_mol TotEng Press Volume Density
2950000    300.44816   -37677.886    44295.361    20505.773    544.40548     224319.2    1.7848003

Original run thermo
Step Temp E_pair E_mol TotEng Press Volume Density
2950000    300.44816   -37679.196    44295.361    20504.462    548.64091     224319.2    1.7848003


As you can see, the diagnostics are not exactly the same. Is this acceptable ?

Please let me know if other files are needed.

Thanks
Soumyadipta


________________________________________
From: Sengupta, S.
Sent: 06 October 2017 17:51
To: lammps-users@...429...96...sourceforge.net
Subject: Restart not exact

I ran a simulation using lambda_test.txt . I am trying to restart the simulation from 2950000 time steps using lambda_rst.txt. I am using the lammps 17Nov/16 version.

The thermo diagnostics for restart are not exactly matching the 2950000 time step data in the log file. I have kept the number of processors same and used the default newton setting in both the restart and original simulation.

Restart thermo

Step Temp E_pair E_mol TotEng Press Volume Density
2950000    300.44816   -37677.886    44295.361    20505.773    544.40548     224319.2    1.7848003

Original run thermo
Step Temp E_pair E_mol TotEng Press Volume Density
2950000    300.44816   -37679.196    44295.361    20504.462    548.64091     224319.2    1.7848003


As you can see, the diagnostics are not exactly the same. Is this acceptable ?

I have attached the log file from the original simulation (log.lammps) and the restart file at 2950000 steps for your reference.

Thanks
Soumyadipta


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
lammps-users mailing list
lammps-users@...6297....sourceforge.net
https://lists.sourceforge.net/lists/listinfo/lammps-users