LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
[lammps-users] Compiling LAMMPS with KOKKOS/CUDA
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lammps-users] Compiling LAMMPS with KOKKOS/CUDA


From: qizhang jia <qj3fe@...2562...>
Date: Tue, 5 Sep 2017 13:59:53 -0400

Hi All,

I'm trying to compiling LAMMPS with KOKKOS/CUDA package. But I'm seeing an error message as follows.

ld: library not found for -lcuda

clang: error: linker command failed with exit code 1 (use -v to see invocation)

make[1]: *** [../lmp_kokkos_cuda] Error 1

make: *** [kokkos_cuda] Error 2


I've tried to locate the -lcuda library but did not find it anywhere. The CUDA version I'm using is 8.0.61. I was wondering if anyone has encountered this before?

Thanks,

Qizhang Jia
DuBay Research Group
University of Virginia