LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] Got "segmentation fault" error when using pari_style quip with gap potential file
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] Got "segmentation fault" error when using pari_style quip with gap potential file


From: Axel Kohlmeyer <akohlmey@...24...>
Date: Wed, 30 Aug 2017 16:34:47 -0400



On Wed, Aug 30, 2017 at 4:21 PM, Tingyu Lu <tlu3@...1442...> wrote:
Hello lammps users,

- I compiled the lammps with quip and gap packages following the guidelines in http://libatoms.github.io/QUIP/install.html and the README files in lammps. The commands from quip and gap works well.

- Then I tested the example "in.sw" in the /lammps/examples/USER/quip/ folder, it worked well, which ensures that I compiled the quip package right. 

- However when I tried the example named "in.gap" which uses the potential from gap, I got the segmentation fault error in the output file. 

- The information in the output file is listed below:

LAMMPS (15 May 2015)
Reading data file ...
  orthogonal box = (0 0 0) to (10.9685 10.9685 10.9685)
  1 by 1 by 2 MPI processor grid
  reading atoms ...
  64 atoms
Neighbor list info ...
  1 neighbor list requests
  update every 1 steps, delay 10 steps, check yes
  master list distance cutoff = 4.3
Setting up run ...

===================================================================================
=   BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
=   EXIT CODE: 11
=   CLEANING UP REMAINING PROCESSES
=   YOU CAN IGNORE THE BELOW CLEANUP MESSAGES
===================================================================================
YOUR APPLICATION TERMINATED WITH THE EXIT STRING: Segmentation fault (signal 11)
This typically refers to a problem with your application.
Please see the FAQ page for debugging suggestions

- My lammps version is "lammps-15May15".

Could you please kindly help me with the problem?

​this is *far* too old a LAMMPS version. there were some recent, incompatible changes in the LAMMPS-QUIP interface.
you need to install LAMMPS version 11Aug2017 or later.

axel.



 

Thanks,
Tingyu



--
Best Regards,
Tingyu Lu
Mechanical and Aerospace Engineering 
911 Oval Dr. - 3404 EBIII
North Carolina State University
Raleigh, NC 27695

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
lammps-users mailing list
lammps-users@...6297....sourceforge.net
https://lists.sourceforge.net/lists/listinfo/lammps-users




--
Dr. Axel Kohlmeyer  akohlmey@...12...24...  http://goo.gl/1wk0
College of Science & Technology, Temple University, Philadelphia PA, USA
International Centre for Theoretical Physics, Trieste. Italy.