LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] Lammps read data and the data file
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] Lammps read data and the data file


From: melika_ bm85 <melika_bm85@...16...>
Date: Tue, 22 Aug 2017 10:28:51 +0430

Dear Phung,
Thank you for your reply. Let me explain myself in detail. I have a simulation box of size 20*20*20 filled with gold atoms ( fcc with lattice parameter 4.08). I have changed the atom coordinates according to this deformation gradient: F= [ 0.5 0 0; 0 1 0; 0 0 1] ( meaning that I applied 50% compression to the atoms in the X direction. Now I want to place my atoms according to this deformed coordinates in the simulation box of size 20*20*20 and let them relax at 1300k. 
I hope I have clarified my question.
Sincerely,
Melika Vokhshoori

Sent from my iPhone

On Aug 22, 2017, at 08:49, Trung Phung <clone.1.trung@...24...> wrote:

Dear Melika,

I actually dont understand what do you mean by "I want to use my own trajectory that I have created in lammps via the read_data command". I guess you want to input atoms position as you wish from data file, and then run with that initial configuration you provided?

If so, then you should get rid of the:
"min_style cg
minimize 1e-15 1e-15 10000 100000"
lines. Since it changes your system configuration to a more stable configuration, which is different to what you have in the data file.

Best regards,
Phung Quoc Trung

2017-08-22 0:34 GMT+09:00 melika_ bm85 via lammps-users <lammps-users@lists.sourceforge.net>:
Dear Lammps users,
I want to use my own trajectory that I have created in lammps via the read_data command. I do it and my code suns with no problem but when I look at the trajectory dump file at step 0 after the run, I see that the atoms are not placed according to the data file I have given lammps as the initial trajectory. It seems to be placing atoms in the simulation box by default. Here is my lammps code and I have also attached the trajectory file that I am using as input for the read_data command. I would really appreciate any help. I cannot figure out what my problem is.
my code:
units metal
dimension 3
boundary p p p
atom_style atomic
lattice fcc 4.08
read_data ref-spatial-traj-1300K.in
pair_style eam
pair_coeff * * auu6.txt
neighbor 0.3 bin
neigh_modify delay 5
compute csym all centro/atom fcc
compute peratom all pe/atom
reset_timestep 0
thermo 1000
timestep 0.001
thermo_style custom step temp pe lx ly lz press pxx pyy pzz
min_style cg
minimize 1e-15 1e-15 10000 100000
reset_timestep 0
velocity all create 1300 4928459 mom yes rot yes dist gaussian
fix 1 all npt temp 1300 1300 1 tri 1 1 10 drag 1
dump trajectory all xyz 5000 dump.xyz
dump 1 all custom 250 dump.tensile.atom id type xs ys zs
run 200000
unfix 1
fix 2 all nvt temp 1300 1300 1 drag 1
compute myRDF all rdf 1000
fix radi all ave/time 1 10000 10000 c_myRDF[*] file tmp.rdf mode vector
run 200000
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
lammps-users mailing list
lammps-users@...6297....sourceforge.net
https://lists.sourceforge.net/lists/listinfo/lammps-users