LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
[lammps-users] imminent new stable release
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lammps-users] imminent new stable release


From: Steve Plimpton <sjplimp@...24...>
Date: Fri, 11 Aug 2017 15:08:17 -0600

Hi - we just posted a 11Aug17 patch, available
as a download tarball or via GitHub, which we
plan to flag as a new "stable" release in a few
days.

It has new options to make building LAMMPS
with auxiliary libraries easier, either
external or provided libs.

You can see help on this, from the src dir,
by typing "make lib-foo" where foo is the
name of the package which requires a library.
E.g. kim, voronoi, gpu, colvars, atc, etc.

The optional args for each package allow
you to download or build or install the library,
as appropriate.

For example, to use models (potentials) from the
KIM project (https://openkim.org) should now
be as easy as this:

make lib-kim args=-b    # download, build KIM lib
make yes-kim            # add KIM package to LAMMPS
make mpi                # build LAMMPS

If you find a new issues with this or other
aspects of the 11Aug17 version in the next few days,
please post to the mail list, and we'll try to
fix it before it becomes the new "stable".

Thanks,
Steve and Axel