LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
Re: [lammps-users] Unable to run LAMMPS due to too many lines in input file
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lammps-users] Unable to run LAMMPS due to too many lines in input file


From: Neil Mehta <neilmehta87@...24...>
Date: Mon, 7 Aug 2017 19:12:00 -0500

Dear Dr. Kohlmeyer,

Thank you for a prompt reply. I model the emission of ionic liquid through an efield generated by a Laplace solver generating regions with varying eField strengths. This pretty much makes it necessary to have these many regions and fixes.
But you did manage to solve my problem. I was using the command "ibrun ./lmp_knl < test_coarse.in" which caused the code to hang up. However, when I use "ibrun ./lmp_mpi -in test_coarse.in" the code started working.
You are awesome.
Thank you so much.

On Mon, Aug 7, 2017 at 6:42 PM, Axel Kohlmeyer <akohlmey@...24...> wrote:


On Mon, Aug 7, 2017 at 6:58 PM, Neil Mehta <neilmehta87@...24...> wrote:
Hi, My name is Neil and I use LAMMPS to perform simulations of ionic liquid electrospray. I perform simulations by pushing the ethylammonium nitrate molecules through a capillary into a region with varying electric field. I have performed simulations of this nature using the previous version of lammps. Recently, however, I tried performing the same simulations on Stampede 2 but I encountered an issue, which is as follows.

I have used lammps version 31st March 2017 and packages Molecule, body, mpiio, kspace, misc, opt, and manybody. For the top level make, i used the Knights landing (KNL) makefile. When I try using my input file, the code generates the following output and hangs
TACC: Starting up job 170904
TACC: Starting parallel tasks...
I realize that I have 1480 lines in my input, with 683 regions and fixes defined to implement the varying electric field. I wanted to verify whether there is a max limit to the number of regions/fixes that can be defined and so I tried performing simulations by commenting out all but one of the regions and fixes defining the electric field (using the # in front of the lines) but the code still did not run. I could isolate the problem to the fact that only if the number of lines were below ~500 lines would the code run (i could use a max of 200 regions/fixes and delete the rest). Am i correct in my process of isolating the problem or do I perform some other checks? Is it possible for me to change some definition of 'maxline' in input.cpp to solve this problem?

‚Äčnobody can debug such a "monster" (in size of script lines and in size of the system), and most definitely nobody on this mailing list will do this.
i also see things and features that could be disabled (e.g. tiled communication, load balancing), since they are optional.
you are just asking for trouble. 

have you tested whether your approach will work with a much(!) smaller test system before embarking on this massive simulation?
what exactly is the reason why you define so many regions and fixes? couldn't you just use fix efield with atom style variables?

please note, that LAMMPS has no limit as to the number of lines (or the length of a line).
you may be hitting a limit of the MPI library. are you using the -in flag or I/O redirection?

axel.





--
Thanks and Regards,
Neil Mehta.

What is gravity...or more profound, what causes gravity
Richard Feynman