LAMMPS WWW Site - LAMMPS Documentation - LAMMPS Mailing List Archives
[lammps-users] Problem with compute cluster/atom
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lammps-users] Problem with compute cluster/atom


From: 1132033@...3237...
Date: Wed, 14 Jun 2017 18:37:54 +0800 (GMT+08:00)

Dear all,

I am using lammps-31Mar17 MPI version. With the script file listed below, I found mpirun -np 1 could produce good result, however, running with more threads like -np 20, the error message comes up like "*** Error in `./lmp_mpi': malloc(): memory corruption (fast): 0x0000000002167da0 ***". 

My computer have two processors "Intel® Xeon(R) CPU E5-2698 v4 @ 2.20GHz × 16" with 40 cores, and the number of threads usually didn't effect the outcome without computing the cluster ID. So I guess the problem has something to do with the compute cluster/atom command.
I wonder if this error is due to a mistake on my side, or a problem in lammps. Please shed some light on this error. Testing the script file and posting your results would also be very helpful. 

Best regards,

Ethan

#----------------------------------------

dimension	3
boundary	p p p
atom_style	atomic
neighbor	0.3 bin
neigh_modify	delay 5

lattice		fcc 1.5
region		box block -10 10 -10 10 -10 10
region		init block -5 5 -5 5 -5 5
create_box	1 box
create_atoms	1 region init
mass		* 1.0
velocity	all create 1.0 19880503 loop geom

pair_style	lj/cut 1.2
pair_coeff	* * 1.0 1.0 1.2

fix		1 all nve/limit 0.001
timestep	0.003
thermo		100
compute		clusterID all cluster/atom 1.2
dump		monitor all custom 500 dump.lammps    id type x y z 	c_clusterID

run		10000